Cascade Oil Test E 1733ng/dl @ 600mg per week?

Topic created · 8 Posts · 566 Views
  • <br />
    <table class=“post” style=“undefined;table-layout: fixed; width: 641px”>
    <tr>
    <th class=“tg-amwm” colspan=“2”><center>Blood Work Review</center></b></th>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Link to blood work :</td>
    <td class=“tg-yw4l”>// https://imgur.com/a/Kmuiwcu//</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Source :</td>
    <td class=“tg-yw4l”>// Cascade Oil //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Running testosterone :</td>
    <td class=“tg-yw4l”>// yes//</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Ester :</td>
    <td class=“tg-yw4l”>// Enanthate //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Weekly dosage :</td>
    <td class=“tg-yw4l”>// 600mg //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Product(s) run other than test :</td>
    <td class=“tg-yw4l”>// Arimidex //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Weekly dosage(s) :</td>
    <td class=“tg-yw4l”>// ~2.375 mg (.25,.5mg ed) //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Number of weeks run :</td>
    <td class=“tg-yw4l”>// four //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Draw time after last pin :</td>
    <td class=“tg-yw4l”>// 40 hours //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-amwm” colspan=“2”><center><strong>Blood Results</center></strong></td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Test reading in ng/dL :</td>
    <td class=“tg-yw4l”>// 1733 //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Test multiplier :</td>
    <td class=“tg-yw4l”>// 2.83x //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Capped at >1500 :</td>
    <td class=“tg-yw4l”>// no //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>E2 reading :</td>
    <td class=“tg-yw4l”>// 16//</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Liver/lipids elevated :</td>
    <td class=“tg-yw4l”>// n/a //</td>
    </tr>
    </table>
    ANYTHING ELSE WORTH MENTIONING GOES BELOW:<br />
    <br />

    Any thoughts on why this is so low? From everything I’ve seen here Cascade is good to go, possible I got a bad vial or something? I’ve never had a weak response like this before a little confused.

    Edited to include screencap with date.

  • [quote=“Richpianoman” pid=‘52748’ dateline=‘1557764628’]
    <br />
    <table class=“post” style=“undefined;table-layout: fixed; width: 641px”>
    <tr>
    <th class=“tg-amwm” colspan=“2”><center>Blood Work Review</center></b></th>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Link to blood work :</td>
    <td class=“tg-yw4l”>// https://imgur.com/a/6R07zWl //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Source :</td>
    <td class=“tg-yw4l”>// Cascade Oil //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Running testosterone :</td>
    <td class=“tg-yw4l”>// yes//</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Ester :</td>
    <td class=“tg-yw4l”>// Enanthate //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Weekly dosage :</td>
    <td class=“tg-yw4l”>// 600mg //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Product(s) run other than test :</td>
    <td class=“tg-yw4l”>// Arimidex //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Weekly dosage(s) :</td>
    <td class=“tg-yw4l”>// ~2.375 mg (.25,.5mg ed) //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Number of weeks run :</td>
    <td class=“tg-yw4l”>// four //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Draw time after last pin :</td>
    <td class=“tg-yw4l”>// 40 hours //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-amwm” colspan=“2”><center><strong>Blood Results</center></strong></td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Test reading in ng/dL :</td>
    <td class=“tg-yw4l”>// 1733 //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Test multiplier :</td>
    <td class=“tg-yw4l”>// 2.83x //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Capped at >1500 :</td>
    <td class=“tg-yw4l”>// no //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>E2 reading :</td>
    <td class=“tg-yw4l”>// 16//</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Liver/lipids elevated :</td>
    <td class=“tg-yw4l”>// n/a //</td>
    </tr>
    </table>
    ANYTHING ELSE WORTH MENTIONING GOES BELOW:<br />
    <br />

    Any thoughts on why this is so low? From everything I’ve seen here Cascade is good to go, possible I got a bad vial or something? I’ve never had a weak response like this before a little confused.
    [/quote]

    I really don’t have any thoughts on why its low. I will say there’s no such thing as a bad vial. That’s not how it works. The Test is not underdosed, so something is not adding up, that’s all I know.

    Also, when posting bloodwork, you need to have the date of when the labs were taken in the same screencap.

  • [quote=“Cascade” pid=‘52823’ dateline=‘1557790717’]
    [quote=“Richpianoman” pid=‘52748’ dateline=‘1557764628’]
    <br />
    <table class=“post” style=“undefined;table-layout: fixed; width: 641px”>
    <tr>
    <th class=“tg-amwm” colspan=“2”><center>Blood Work Review</center></b></th>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Link to blood work :</td>
    <td class=“tg-yw4l”>// https://imgur.com/a/6R07zWl //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Source :</td>
    <td class=“tg-yw4l”>// Cascade Oil //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Running testosterone :</td>
    <td class=“tg-yw4l”>// yes//</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Ester :</td>
    <td class=“tg-yw4l”>// Enanthate //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Weekly dosage :</td>
    <td class=“tg-yw4l”>// 600mg //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Product(s) run other than test :</td>
    <td class=“tg-yw4l”>// Arimidex //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Weekly dosage(s) :</td>
    <td class=“tg-yw4l”>// ~2.375 mg (.25,.5mg ed) //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Number of weeks run :</td>
    <td class=“tg-yw4l”>// four //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Draw time after last pin :</td>
    <td class=“tg-yw4l”>// 40 hours //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-amwm” colspan=“2”><center><strong>Blood Results</center></strong></td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Test reading in ng/dL :</td>
    <td class=“tg-yw4l”>// 1733 //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Test multiplier :</td>
    <td class=“tg-yw4l”>// 2.83x //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Capped at >1500 :</td>
    <td class=“tg-yw4l”>// no //</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>E2 reading :</td>
    <td class=“tg-yw4l”>// 16//</td>
    </tr>
    <tr class=“post”>
    <td class=“tg-l2oz”>Liver/lipids elevated :</td>
    <td class=“tg-yw4l”>// n/a //</td>
    </tr>
    </table>
    ANYTHING ELSE WORTH MENTIONING GOES BELOW:<br />
    <br />

    Any thoughts on why this is so low? From everything I’ve seen here Cascade is good to go, possible I got a bad vial or something? I’ve never had a weak response like this before a little confused.
    [/quote]

    I really don’t have any thoughts on why its low. I will say there’s no such thing as a bad vial. That’s not how it works. The Test is not underdosed, so something is not adding up, that’s all I know.

    Also, when posting bloodwork, you need to have the date of when the labs were taken in the same screencap.
    [/quote]

    Edited to include screencap with date. Not sure what else it could be then unless the lab somehow fucked it up don’t know how prevalent that is.

  • I’m running Cascade’s Test E too. On week 5 and will get bloods next week. What batch number?

  • It is strange because 600 a week is a pretty decent dose to only get 1700+ when the other guy in another section got 1600 on 200 a week. !!! Not sure what to think. Could you be THAT low of a responder? Has anyone seen numbers this low for that much test?

  • He’s only been on for 4 weeks. Most test e bloods you want to wait 5 weeks so he might not be saturated yet.

  • [quote=“propionate” pid=‘53097’ dateline=‘1557946829’]
    He’s only been on for 4 weeks. Most test e bloods you want to wait 5 weeks so he might not be saturated yet.
    [/quote]

    This was just 4 weeks on this source, was on lock and load test e same dose prior to this for 6 weeks and had bloodwork at 2847 ng/dl.

  • [quote=“Richpianoman” pid=‘53111’ dateline=‘1557951564’]
    [quote=“propionate” pid=‘53097’ dateline=‘1557946829’]
    He’s only been on for 4 weeks. Most test e bloods you want to wait 5 weeks so he might not be saturated yet.
    [/quote]

    This was just 4 weeks on this source, was on lock and load test e same dose prior to this for 6 weeks and had bloodwork at 2847 ng/dl.
    [/quote]

    So basically you just swapped brands? If so, interesting results.

Log in to reply